KuCoin's Reminder on Plugins Usage Security

2019/04/03 20:14:06Announcements

Dear KuCoin Users,

For your account security, KuCoin reminds:

Please do not use Chrome plugins, developer mode scripts and other plug-in-assisted transactions from unknown sources, as this may result in your password leakage, posing a significant risk to your funds and transaction security.

Thank you for your support!

The KuCoin Team